Petit problème avec mon tricoptere

Tout savoir pour fabriquer un drone DIY Forums Général Petit problème avec mon tricoptere

Ce sujet a 31 réponses, 5 participants et a été mis à jour par Photo du profil de Dronadair Dronadair, il y a 4 ans.

30 sujets de 1 à 30 (sur un total de 32)
  • Auteur
    Messages
  • #46085
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Bonjour tout le monde.
    Voilà mon tri est fini de monter mais impossible de le faire voler. Il tourne toujours en rond et je n’arrive pas à comprendre le probleme.
    Je pensée que s’était du au servo qui contrôle la direction qui été trop faible mais je ne pense pas. C’est un 2kg en 5v. Je pense pas que sa vienne de cela.

    A l’aide

    Merci

    fichiers attachés:
    You must be logged in to view attached files.
    #46103
    Photo du profil de madino
    madino
    Participant
    • Messages : 92
    • Offline

    Sens de rotation des moteurs correct ?

    #46104
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Alors j’ai suivi le tuto de dronadaire et respecter le sens de rotation qui dit,mais impossible de le changer sur cleanflight.

    #46111
    Photo du profil de louff
    louff
    Participant
    • Messages : 305
    • Offline

    salut , pour changer le sens de rotation il faut croiser 2 fil

    …._______fil 1_________motor fil 1
    esc _______fil 2_________motor fil 2 premier sens
    …._______fil 3_________motor fil 3

    …._______fil 1_________motor fil 2
    esc _______fil 2_________motor fil 1 2me sens
    …._______fil 3_________motor fil 3

    par rapport a ta photo et au sens de montage de tes hélice

    le moteur arrière tourne sens antihoraire
    le moteur avant droit aussi
    le moteur avant gauche horaire

    je remarque aussi que le moteur arrière na pas l’air d’être bien a 90° , peut être que l’angle de la photo me trompe,mais on dirai qu’il penche a gauche

    #46113
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Salut
    Oui mes hélices tournent bien comme tu dit et oui mon servo arrière est de travers impossible de le mettre droit mécaniquement après dans le cleanflight je c’est pas

    Merci de ton aide

    #46114
    Photo du profil de louff
    louff
    Participant
    • Messages : 305
    • Offline

    test de changer la valeur de mid c’est la position centrale

    fichiers attachés:
    You must be logged in to view attached files.
    #46117
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    S’il tourne en rond, tu as surement ton servo qui tourne dans le mauvais sens. Fait un test à la main, sans hélice.
    Fait ceci:
    Moteur désarmé, tourne le tricopter à la main, disons dans le sens horaire, en vue de dessus, et dis nous dans quel sens tourne le servo (gauche ou droite), quand tu le vois disons de derrière le bras portant le servo, depuis l’extérieur (sinon gauche ou droite ne voudra rien dire pour nous). Idéalement filme le test pour le mettre sur youtube pour éviter toute confusion.

    Merci

    #46118
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Ok je vais voir sa se soir
    Merci

    Et sa pourrais corriger le problème de rotation ?

    #46119
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Ouai mais si je change le mid je vais avoir un côté qui penche plus que l’autre.

    #46120
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Salut dronadaire cela voudrais dire qu’il compenserai du mauvais côté.

    Pourquoi j’y est pas pensé

    Merci

    #46121
    Photo du profil de louff
    louff
    Participant
    • Messages : 305
    • Offline

    fait nous un gros plan de ton montage de queu

    #46122
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Attention sa peut prêter à confusion.

    Mdr

    #46123
    Photo du profil de louff
    louff
    Participant
    • Messages : 305
    • Offline

    c’est vrai mdr :))

    #46125
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    @worms60

    Oui, il compenserait dans le mauvais sens. Selon les servos, ils vont tourner dans un sens ou dans l’autre. Le GUI de cleanflight te permet d’inverser le sens. Je dois faire ça avec 1 servo sur deux. C’est pour ça que je t’ai demandé de faire ce test avant de te tester toute autre chose. Le mid point n’est pas le problème dans ton cas, et il est justement normal que la position à l’arret soit un peu incliné, c’est pour donner un contre-couple.

    #46127
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Merci pour votre aide les gars. J’essaie sa en rentrant se soir vers 16h et je posterai le résultat.

    #46130
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Bon ben c’est bien sa il corrige a l’envers mais sur cleanflight il ne veut pas me le passer en reverse

    #46131
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    Ok, rien de délirant donc. Pour Cleanflight, patiente d’ici ce soir, je vais regarder de près, car Dominic (l’auteur de cleanflight) a changé des trucs lié au tricopter que je lui avais demandé, et en faisant ça il a changé le code pour les servos. Je vais regarder ce qu’il en est ce soir. Confirme moi juste ta version du firmware que tu avais chargé dans ton Naze32 avec Cleanflight. Pour me donner l’info sans t’embeter, fais juste une capture d’écran après avoir fait « connect », ça suffira. Merci

    #46132
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    C’est une flip32 et c’est 1.9.0

    fichiers attachés:
    You must be logged in to view attached files.
    #46134
    Photo du profil de PapyMaurice
    PapyMaurice
    Admin bbPress
    • Messages : 953
    • Offline

    On voit rien @worms60, une vraie capture d’écran serait beaucoup mieux 🙂

    #46138
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Dsl pour cette photo.

    Bon c’est bon sa marche.
    En faite la version 1.9.0 à un défaut et il est impossible de passer le servo de mon tri en reverse.
    Mais en fouillant sur le net j’ai trouvé ceci :
    Allez sous l’onglet CLIP et taper
    servo 5 1100 1900 1500 101 -1 ( respecter les espaces surtout )
    Entrer
    Save
    Entrer
    Puis retourner dans l’onglet de servo et pouf c’est reverse.

    Maintenant il me reste plus qu’à programmer mes aux, mais qui aurez quelque liens qui explique très bien pour mettre angle acro ou autre truc de possible avec ces aux.

    Merci à vous

    #46139
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    Ok là en CLI, tu as fait du reverse mais d’autres modifs aussi, que je voulais t’éviter de faire. Si ton Yaw a un comportement inattendu préviens moi. Sinon, c’est cool 🙂

    #46140
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Ben il a l’air de se comporter correctement. Quels sont les problèmes qui pourront se produire.

    Merci

    #46141
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    Ok, autant ne pas compliquer les choses, si tu es satisfait de ces valeurs, n’y revient pas dessus. Va, vole, et reviens 🙂
    Content de voir un nouveau tricopter sur le site, n’hésite pas à nous faire part d’un retour d’expérience, photos, …

    #46144
    Photo du profil de louff
    louff
    Participant
    • Messages : 305
    • Offline

    regarde dans le sujet « approfondissement cleanflight et radio » sur le forum j’en ai un peu parle

    http://www.mondrone.net/forums/topic/approfondissement-cleanflight-et-radio/

    #46159
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Salut tout le monde.
    Bon ben j’ai effectué mes premiers vols et déjà un probleme.
    J’ai fait une petite chute pas très haut et j’ai mon servo arrière qui fait des blocages, du côté droit (75°) parfait mais du côté gauche impossible d’aller au delà des 30°.

    Est ce que mon servo aurais été touché et si oui le remplacer par quoi

    Merci à vous.

    #46164
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    Pour constater ces blocages, tu le fais bouger à la main ou via ta radio-commande en bougeant ta commande de Yaw ?
    Avais-tu fais ces mêmes tests avant le crash ?

    #46165
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Ouai à la main et avant j’avais tout correct ft en le faisant à la télécommande on voit bien que sa penche plus d’un côté que de l’autre.

    #46167
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    As-tu un servo tester ?

    #46168
    Photo du profil de Worms60
    Worms60
    Participant
    • Messages : 38
    • Offline

    Non, sa arrive souvent sa sur les tri

    #46169
    Photo du profil de Dronadair
    Dronadair
    Modérateur
    • Messages : 52
    • Offline

    Ça ne m’est jamais arrivé avec mes servos, j’ai 4 tri à mon actif, 4 servos différents, mais je prends généralement du haut de gamme en servo.
    Menfin peu t’importe. Comme indiqué dans mon tuto, pour fabriquer un tri, il te faut un testeur de servo. Car un pignon mal serré bouge lors d’un crash. Le testeur de servo t’évite de bidouiller dans tous les sens pour t’assurer que ton servo est bien centré mécaniquement avant de serrer tes pignons. Là sans testeur de servo, il faut que tu testes à la main où est ton « milieu » de course pour remettre ton pignon au bon endroit. Malheureusement, sans testeur de servo tu peux pas vraiment savoir si ton servo a pris cher lors du crash. Faut que t’essaies à la radio pour voir si, une fois recentré, il bouge bien autant dans un sens que dans l’autre. Par ailleurs, avec ta commande cli, tu as un peu restraint la course, donc c’est normal s’il ne bouge pas avec la même amplitude à la radio par rapport à l’amplitude que tu vois en le bougeant à la main.
    Qu’as-tu comme servo ? Celui du tuto je l’ai, et il peut encaisser.

30 sujets de 1 à 30 (sur un total de 32)

Vous devez être connecté pour répondre à ce sujet.

X
- Entrez votre position -
- or -