Fin de préparation de mon drone

Tout savoir pour fabriquer un drone DIY Forums Général Fin de préparation de mon drone

Mots-clés : , ,

30 sujets de 1 à 30 (sur un total de 30)
  • Auteur
    Messages
  • #59976
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Bonjour,

    J’ai construit mon drone (presque en entier, il manque le tx et la caméra, mais j’ai tout le reste.
    Le problème, c’est que quand je met la batterie, RIEN NE SE PASSE, rien du tout !
    Donc j’ai regardé avec un instrument qui mesure l’intensité du courant s’il passait, et il passe du + de la batterie, a tous les plus, jusqu’au moins de partout. Mais après c’est de les moins de partout au moins de la batterie…

    J’ai regardé et re-regardé les branchements, mais pour moi, ça m’a l’air comme la vidéo de UAVfutures :/

    Que faire ?

    Merci beaucoup pour votre répondre,
    Cordialement,
    Aristidee

    #59977
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Et/Ou, comment mettre à jour ce truc ?
    F3 Flight Controller Acro 6 DOF/Deluxe 10 DOF for Multirotor Racing

    Je n’ai pas trop compris 🙂

    #59978
    Aristidee
    Participant
    • Messages : 101
    • Offline
    #59982
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Salut @aristidee

    On va t’aider.
    Déjà, ce serait sympa que tu te présentes dans la section prévue…

    Avant de faire voler ton quad, il faut impérativement que tu passes par la case paramétrage sous Cleanflight ou Betaflight.

    Tu as fait quoi concrètement? Tu l’as assemblé et voilà?

    #59983
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Ta vidéo était QUE pour le montage.

    Maintenant regarde ça https://blog-rc.tidom.net/naze32-configuration-cleanflight-betaflight/ et amuse toi 😉

    Petit conseil : oublie Cleanflight, prend Betaflight

    #59984
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Hop popop stop!!!!!!!!

    Sur ta photo ce n’est pas bon du tout! Ne branche rien!

    Le gros fil rouge OK
    Le gros fil noir OK
    Le petit blanc, c’est le signal de ton ESC, il va sur ta FC, mais je ne vois rien sur ta photo.
    Le petit fil noir, tu l’as soudé avec le gros???????? Surtout pas!!!!!!! Et je vois que tu l’as coupé en plus…….

    Pour faire simple, ce qui était à l’origine sur la fiche servo (fil noir ET blanc) se branche sur la FC.

    Il y a beaucoup d’exemples/tutos sur le net ou encore sur youtube, va jeter un œil.

    Prend plusieurs photos, notamment de ta PCB complète et de ta FC. Je suis curieux là ^^

    #59985
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Déjà merci beaucoup pour ta réponse.
    Je vais de suite me présenter 🙂

    Je ne l’ai pas du tout paramétré, quand je connect le controlleur à mon ordi et la batterie, il dit 0V.
    Donc que faire ?

    Effectivement, j’ai juste assemblé le drone (sans la caméra et le RX)

    Quand je me connect avec clean Flight, il me disent de mettre à jour le truc.
    Alors je suis passé en version antérieure, soit 1.2 il me semble.

    Photo supplémentaire: http://hpics.li/a44efb4
    Vidéo avec laquel j’ai fais mon drone: https://www.youtube.com/watch?v=iURdanOCFIA
    A 13minutes, les petits fils noir sont comme moi (il les installent)

    Merci pour le soutient de mon ignorance 🙂

    #59986
    Metogon
    Participant
    • Messages : 58
    • Offline

    Bonjour,

    J’ai l’impression que c’est ta F3 qui est mal alimentée. T’as soudé 2 fils noirs exprès ou pas ?

    #59987
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Comme su la vidéo 🙂

    Bon, j’ai réussit à alimenter toute ma carte en passant par d’autres ports d’alimentations.
    Tout s’allume correctement !

    Problème, alors quelque ré-allumage, (le tout n’était pas encore souder et il y a eu quelques étincelle mais au début tout fonctionner encore), le nouveau probème est que le controlleur ne veut plus allumer ses leds. Pourtant, le courant passe toujours dedans ! 4,90V inscrit.

    Pourquoi les 2 derniers bruits du PDB ne sont plus là et pouquoi les leds ne veulent plus s’allumer ? Le controlleur n’est plus reconnu sur CleanFlight?

    #59988
    Aristidee
    Participant
    • Messages : 101
    • Offline

    J’ai suivit le tuto pour mettre à jour, avec full ship erase, mais il me dire que les ports sont fermé, donc pas possible.
    Toujours aucune LED et pas la fin du bruit.

    Est-ce que j’ai pu le cramer alors que les volts passent toujours dedans ?

    #59992
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Et @Metogon, la carte ne veut pas s’allumer même quand je la branche avec l’ordinateur.

    #59993
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Et c’est bizarre, car le courant passe effectivement dans tous le contrôleur et l’ordinateur quand je le connecte dis que quelque chose vient de se connecter.

    #60005
    Aristidee
    Participant
    • Messages : 101
    • Offline

    J’ai commander deux nouvelles pièces: PDB et Contrôlleur, je compte sur vous pour me dire que faire désormais, car apparement, j’ai tout mal fait. Alors je compte sur vous 🙂

    #60024
    Aristidee
    Participant
    • Messages : 101
    • Offline

    @Batbat, alors ?

    #60025
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Tu viens de me citer, donc j’ai vu toutes tes réponses. Tu aurais dû me citer avant.

    Pour être franc, je ne comprends pas bien comment tu as assemblé ta machine. Et je pense que tu fais fausse route, en tout cas, c’est ce que j’en déduis lorsque je lis tout tes posts.

    Si en plus tu as eu des étincelles quelque part, arrête tout!

    Mais ce n’est pas grave! On va reprendre depuis le début. Ca va être un peu long, mais si tu valides toutes les étapes que je décris ci dessous, ça devrait bien se passer (et je vais me dépêcher de publier mon premier tuto du coup^^ je pense que ça t’aurait servi.)

    Bon, ce qui est le plus important, c’est de BIEN souder les 3 fils moteurs aux trois pastilles des ESC, dans n’importe quel ordre, c’est pas grave pour l’instant. Ca tu l’as bien fait.

    Puis, tu pars de tes ESC. Tu vas souder sur la PDB les alimentations (les fils rouge et noir SEULEMENT).
    Encore sur la PDB, tu vas devoir alimenter ta FC en soudant deux fils sur le BEC 5V (- et +) qui vont à leurs tour être soudé sur la piste 5, 6, 7 ou 8 d’un ESC, sur le + et sur le -. Là, ta FC sera alimenter en permanence par un « bon » 5V. Les UART sont présents pour autre chose, contrairement à ce que tu as fait je crois.
    Sur ta photo, ta FC n’est pas alimenté en 5V! Donc tu ne pourras jamais initialiser les accéléromètres.

    Sur ta FC, je vois que tu as souder QUE le signal (fil blanc) et pas le noir. Pourquoi!!!!! Le noir de l’ESC 1 vient se souder sur le -, avec le signal de l’ESC 1, etc……

    Et je ne vois pas ton RX non plus! Pourquoi?

    Tu aurais dû te documenter un peu plus avant de commencer. J’espère que tu n’as rien cramé de tes composants, sinon, il va falloir que tu rachètes des choses.

    Et dernière chose. Tes ESC sont tout nus, comme ça sur ta frame. Le carbone est conducteur, faut que tu les isoles avec de la gaine thermo.
    Idem pour ta PDB, je ne sais pas ce qu’il y a en dessous, mais si elle n’est pas monté sur des entretoises nylon, ça va faire pschittttttt quand tu vas alimenter avec ta lipo.

    #60026
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    et la vidéo en Anglais, pour un débutant, c’est pas le top….

    #60028
    Metogon
    Participant
    • Messages : 58
    • Offline

    Heu au fait quand tu dis éteincelles c’était où en fait ?

    Et au fait petite astuce pour éviter certains court-cricuits: teste avec un multimètre la résistance entre les 2 bornes du connecteur soudé sur la PDB avant de brancher la lipo, si t’as une valeur proche de 0 Ohm c’est pas bon.

    #60029
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Les étincelles au niveau du PDB pour la première et au niveau de mes doigts pour ma deuxième, je me suis coupé…
    Ne reproduisez pas ca chez vous, enfin je vous le conseil.

    @Batbat @Batbat 😊

    J’achète de la grosse gaine thermo retractable demain car j’en avais, mais du petit pour les files donc je le mettrais autour des ESC, il manque à savoir comment les accrochers au frame maintenant.

    J’ai déjà coupé le petit file noir, je fais comment ? Je rajoute un autre file que je met à la suite en rajoutant une gaine ?

    Deuxième question, comment faire pour que le PDB ne colle pas au frame ? Un bout de Scotch en dessous suffit ? Car normalemnt j’ai deux 12 visses dufferentes. 4 de départ (une de chaque côté) puis 8 autres (qui se visse les une sur les autres), sauf que moi j’en ai eu que quatre de cette sorte, donc j’aI fais avec les moyens du bord 😊

    J’espère que je suis assez clair,

    En tout cas, @Batbat, ta réponse à été hyper bien faite et tu réponds vraiment à mon sujet et à mes questions, je te remercie beaucoup pour cette réponse !
    Mais je veux bien savoir la suite pour la construction en plus des questions👷 😊

    Question optionnel: À quoi sert le + sur le FC ?

    Ps: Je conpte aussi m’acheter un pistolet à colle chaude, cela serat-il utile ?

    Merci à vous deux pour votre soutient 😊☺😉

    #60033
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Nous sommes là pour ça @aristidee 😉

    Gaine thermo ou scotch d’électricien, ça fait le boulot. Après tu fixes tes ESC aux bras, soit avec un colson, soit encore avec du scotch d’électricien. Perso, j’utilise la deuxième solution et c’est parfait, et ça fait propre.

    Pour ton – de l’ESC, oui tu peux faire une rallonge et ensuite l’isoler.

    Les pins + sur la FC étaient pour les ESC munis de fils +. Tu en raccordais un, et ta FC était alimenter par un ESC. Mais maintenant, ils sont tous opto (sans le +).

    Pour surélever ta PDB de ta frame, il te faut des vis nylon. C’est l’outil indispensable du modéliste.
    Tu peux les trouver ici : Vis nylon BG ou sur un shop en France si tu les souhaites plus rapidement.
    L’avantage de la fixer avec ces vis, c’est qu’elle sera à niveau, et donc ta FC sera bien à plat aussi, et c’est IN-DIS-PEN-SA-BLE!

    Un pistolet à colle chaude te servira sûrement un jour. J’en ai un depuis deux ans, je m’en suis servi une fois…. C’est light!

    PS : je suis en train de rédiger un tuto pour les bases, l’assemblage d’un quadri, et le paramétrage sous BTF. Mais il ne sera pas assez clair je pense pour tout le monde. J’attends la période estivale pour mettre à jour une machine actuelle. j’en profiterais pour faire quelques choses de détaillé avec beaucoup de photos explicatives.

    Si tu as besoin d’autre chose, n’hésite pas.

    #60039
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Tu es un ange @Batbat ! 💗

    Et par rapport aux photo que j’ai posté avant, peux tu me confirmer que le file bleu VBAT+ va sur le controlleur VBAT sur le + ? Mais du coup, il n’y a pas de VBAT – :/

    #60045
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Tu es daltonien @aristidee????

    Je ne vois pas de fil bleu…..

    Et sais tu ce que c’est que le VBAT?

    Le VBAT est une petite prise qui vient se brancher sur la FC. Elle a un fil rouge et un fil noir. Le noir sera à souder sur un pad – d’un ESC sur ta PDB, et le rouge sur un pad + d’un ESC sur ta PDB. n’importe lesquels.
    Ensuite, tu peux programmer la télémétrie sur ta FC. Ce qui te permettra de garder un œil sur la puissance restante dans ta lipo.
    Perso, j’ai programmé un switch sur ma Taranis pour qu’elle me dicte ce qu’il me reste en puissance.

    Mais bon, là, c’est autre chose, c’est un peu plus compliqué que d’assembler un quad! Enfin, je trouve….

    #60051
    Aristidee
    Participant
    • Messages : 101
    • Offline

    As-Tu fais un tutoriel pour mettre la télémétrie ? @Batbat

    Sur mon Eachine TX526, j’ai deux GND, un à côté du rouge et l’autre à l’opposé du rouge, je fais quoi de celui à l’opposé du fil rouge ?

    Dernière chose, pour mon RX, j’ai un connecteur 3 pin en sortie, et au lieu de le couper, je me demandais si cela n’était pas possible de le mettre directement sur le FC

    #60053
    Aristidee
    Participant
    • Messages : 101
    • Offline

    .

    #60070
    Aristidee
    Participant
    • Messages : 101
    • Offline
    #60073
    Neuwak
    Participant
    • Messages : 40
    • Offline

    Ton connecteur 3 pins c’est un mode de communication entre ton RX et ta FC appelé le PPM ou CPPM. C’est super pratique pour gagner de la place et du poids par rapport aux branchement traditionnel à 10 cables pour les 8 voies et l’alimentation du RX. Là t’as 2 cables pour l’alim et un pour le signal des 8 voies! Après en PPM t’as légèrement plus de latence mais y a d’autres modes comme le SBUS ou IBUS qui peuvent carrément la réduire à beaucoup moins, le problème c’est que ces 2 modes ont besoin d’être compatibles et pas mal de radios n’ont pas ces fonctionnalitées ( c’est mon cas c’est pourquoi j’utilise le PPM). Donc ne coupe pas ces fils c’est mieux… Après je suis aussi débutant mais j’ai pratiquement fini de monter mon premier drone (encore quelques réglages) et il vole à peu près pour l’instant. Et à la place de couper tes fils y a toujours un moyen de les décrocher proprement avec un cutter au niveau de la fiche… Comme ça tu peux les remettre si besoin mais attention c’est souvent fragile…

    #60081
    Aristidee
    Participant
    • Messages : 101
    • Offline

    Mais du coup, je le fixe ou sur mon FC le connecteur à 3 pin ?

    #60089
    Neuwak
    Participant
    • Messages : 40
    • Offline

    Ce qui est cool c’est que t’as la même FC que moi😉 donc t’as un port IO 1 du côté droit de ta carte, il faut que tu prennes seulement les 3 premiers cables, (rouge noir et signal, je ne sais plus quelle couleur) et les brancher sur ton récepteur qui doit être mis en mode PPM aussi, pas compliqué mais ça peut dépendre des modèles de RX donc faut que tu me donne la référence du tien ou alors regarde la doc dessus c’est expliqué.
    Je te file un fichier de la FC qui m’a été bien utile pour tout brancher correctement avec un schéma montrant la prise IO 1😉

    Attachments:
    You must be logged in to view attached files.
    #60091
    Neuwak
    Participant
    • Messages : 40
    • Offline

    Souvent pour que ton RX balance du PPM à la FC il faut faire un pont entre les voies 3 et 4 du RX mais ça peut varier en fonction des models… Y en a qui ont carrément un port dédié au PPM.

    #60092
    Batbat
    Maître des clés
    • Messages : 1850
    • Offline

    Je vois tes messages de mon retour de grand week-end 😉

    Je ne peux pas trop te dire quoi faire pour le coup, je suis en XSR de FrSky, en IBUS….

    Mais il me semble que @neuwak a la bonne solution. Par contre, l’histoire du pont j’ai un peu de mal à saisir…

    #60098
    Neuwak
    Participant
    • Messages : 40
    • Offline

    Sur mon RX, un Fr Sky D8R XP dans mes souvenirs, il faut que je fasse un pont entre les ports 3 et 4 pour que le RX me donne du PPM en port 1

30 sujets de 1 à 30 (sur un total de 30)
  • Vous devez être connecté pour répondre à ce sujet.