Drone qui va (trop) de l'avant

Tout savoir pour fabriquer un drone DIY Forums Vos réalisations Drone qui va (trop) de l'avant

Ce sujet a 12 réponses, 4 participants et a été mis à jour par  vpo92, il y a 2 ans et 2 mois.

13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #60594

    vpo92
    Participant
    • Messages : 12
    • Offline

    Bonjour à tous,

    J’ai poursuivi la construction de mon premier drone et fait un premier vol d’essai qui a couté la vie a un de ses 4 moteurs…
    Une fois changé, j’ai pu recommencer avec un second vol qui, même si il n’y a pas eu de casse ne m’a pas permis de le stabiliser en vol.

    En gros, je met les gaz à fond pour qu’il décolle, ce qu’il fait, mais en suite, il avance tout seul, et si je réduis les gaz, il retombe (pas en douceur) sur le sol…

    Est-ce que vous savez comment je peux le stabiliser ? Je n’ai même pas pu tester les réglage de PID tellement il part vite…
    La FC est une Naze32 rev6, il a 4 moteur 2200kv et tourne sous beta flight… car je n’arrive pas à mettre autre chose avec mon macbook sous osX…

    Merci d’avance 🙂 !

    Edit : j’ajoute une photo, c’est toujours plus sympa !

    Vincent

    Attachments:
    You must be logged in to view attached files.
    #60606

    vpo92
    Participant
    • Messages : 12
    • Offline

    Hello !

    Petit update. Après quelques tests, je me suis rendu compte qu’un des moteurs s’emballe tout seul. Si le le monitor avec Base flight, dès que je met un tout petit peu de gaz il monte progressivement de 1100 à 1800 tout seul, pendant que les autres restent stables. Il s’agit du moteur arrière gauche, ce qui explique peut être pourquoi il part en avant vers la droite….

    J’ai fait une recalibration des ESC, mais cela ne change rien.
    Est-ce que l’ESC est mort ? ou une autre idée ?

    Merci d’avance.

    Vincent

    #60609

    vpo92
    Participant
    • Messages : 12
    • Offline

    Update : j’ai résolu le pb en réinitialisant les options sous baseflight. Cependant mon vol d’essai n’a pas été très concluant… J’ai perdu un écrou d’hélice… snif

    Entre temps j’ai réussi à flasher ma carte sous Cleanflight ce qui me donne pas mal d’options. Je vais voir si je m’en sors mieux comme ça, mais pour l’instant, suite à ce changement, j’ai 2 moteurs qui ne tournent plus… Je cherche pkoi, si vous avez des idées…

    Bonne soirée !

    Vincent

    #60614

    Batbat
    Admin bbPress
    • Messages : 1848
    • Offline

    Je reprends tout ton post! Et bonjour!

    Avais tu recalibré tes ESC?
    Et si tu voles dans un mode stabilisé, il faudrait que tu calibres les accéléromètres 😉

    Concernant Betaflight, c’est le top, tu peux rester avec.

    Contrôle bien tes soudures. Si tu as deux moteurs qui ne tournent plus, ça peut venir de là.

    #60615

    vpo92
    Participant
    • Messages : 12
    • Offline

    Merci BatBat pour tes conseils.
    Je suis donc sur BetaFlight et j’ai résolu mes soucis.
    Après divers test des ESC (en les branchant directement sur le recepteur), j’ai exclu le soucis de soudure.
    J’ai réglé le problème un peu au pif, en changeant le menu « esc/motor protocol » pour la valeur PMW.
    Je ne sais pas du tout à quoi cela correspond, mais mes 4 moteurs tournent maintenant :). si kk1 à l’info je suis preneur.
    Il me reste donc à tester lors d’un nouveau vol.

    Merci !

    #60617

    vpo92
    Participant
    • Messages : 12
    • Offline

    Premier vol digne de ce non réalisé !
    Je suis passé en mode « angle » et la le drone était plutôt stable et contrôlable même si il dérive pas mal (il y avait du vent). Il reste donc des réglages à faire.
    Prochaine étape : j’ajoute le bluetooth pour régler les fameux PID.

    ++

    #60635

    Batbat
    Admin bbPress
    • Messages : 1848
    • Offline

    Félicitations @vpo92 pour ton maiden!

    Oui, les modes ANGLE et HORIZON sont des modes stabilisés. Mais je te conseilles de passer rapidement au mode ACRO, tu pourras alors contrôler ta machine sur le bout des doigts.

    Pour le réglages des PID, je t’invite à suivre ce tuto très bien fait : AIR SANGLIER

    Et un simple cable USB OTG suffit à la place du BT, mais là, c’est une question de goût 😉

    #60652

    vpo92
    Participant
    • Messages : 12
    • Offline

    Merci BatBat, je vais faire ça en OTG alors 🙂

    #60758

    vpo92
    Participant
    • Messages : 12
    • Offline

    Hello,

    Je n’ai pas pu refaire d’essai de vol, donc en attendant, j’ai installé une (caméra). Au premier essai, cela a fonctionné parfaitement. J’ai acheté un (récepteur EACHINA) qui se branche sur mon smartphone et en installant l’appli, j’ai bien eu la bonne image.

    Mais sans que je ne touche à rien (intentionnellement en tout cas), cela ne fonctionne plus… l’écran m’affiche une image pleine de parasite. J’ai fait un balayage de toutes les fréquences, sans succès. J’ai chanté la fréquence d’émission sur le transmetteur, et la aussi pas de résultat.

    Comme j’ai pensé a un pb de caméra, je l’ai testé sur ma TV en branchant un cable RCA, et elle fonctionne bien.

    Je pense qu’il y a donc un soucis entre le transmetteur et le récepteur… mais comment savoir lequel des deux ne fonctionne pas ?

    Si vous avez une astuce je suis preneur, sinon… je suis bon pour racheter un des deux au pif 🙂

    Merci d’avance !

    #60761

    McDel
    Participant
    • Messages : 269
    • Offline

    @vpo92 : salut, tu as bien fait de tester ta cam sur un autre support donc le blème ne vient pas de la caméra. Vérifies tes connections, que tout soit bien enfoncé car à l’oeil nu = pas tjr évident. Si tjr le même problème = souci de défaillante ce qui peut arriver d’après ce que j’ai pu voir sur qqs groupes FB. Je pencherai plusss pour le récepteur mais bon qu’est-ce que tu en penses, Batbat ?

    PWM / PPM
    PWM : 1 câble par canal
    PPM : 1 câble connectant plusieurs canaux

    Euh tu sais que sur BG l’OTG il est à moitié prix ? arf
    Eachine ROTG01

    PS : quand tu envoies des liens redirectionnels, tu peux cocher « ouvrir le lien dans un 2eme onglet »? c’est+pratique ^^

    #60777

    vpo92
    Participant
    • Messages : 12
    • Offline

    Merci du tuyau, je vais faire une commande sur BG.
    Vu les bonnes affaires, je vais commander les 2 (transmetteurs + récepteur), ça me servira bien un jour 🙂 !

    PS : j’ai corrigé les liens

    #60778

    Aristidee
    Participant
    • Messages : 101
    • Offline

    Par rapport à ce tutos: http://www.airsanglier.com/2016/04/tuning-pid-pousser-votre-machine-aux-limites/
    Que signifie le mot oscillation ? Enfin, qu’est ce que cela fait sur le drone ?

    #61008

    vpo92
    Participant
    • Messages : 12
    • Offline

    Re !

    Ca y est, mon colis est arrivé. Le fautif était…; l’émetteur !
    Je l’ai changé, donc je suis maintenant prêt à voler.

    Je vous envoi une vidéo… si ça marche 🙂

    Merci !

    @arisidee : dsl, pas encore expert pour te répondre…

13 sujets de 1 à 13 (sur un total de 13)

Vous devez être connecté pour répondre à ce sujet.