1er drone, NightHawk 250 !

18 sujets de 1 à 18 (sur un total de 18)
  • Auteur
    Messages
  • #55871
    Bibi
    Participant
    • Messages : 7
    • Offline

    Bonjour a tous,
    Nouveau et nouveau projet pour moi.
    Comme beaucoup ici j’ai décidé de fabriquer mon drone.
    Faisant du modélisme depuis un ptit moment (voiture piste/drift, avion, drone…),
    je trouvais ça plus fun de le construire moi même.

    Je me suis donc arrêté sur le châssis Nighthawk
    Nighthawk 250

    Et en config j’ai opté pour:
    La NAZE32 de chez banggood
    Une carte de distribution Matek
    Un pack de 4 moteurs Power Combo 5030 Properller 1806-2300KV
    avec ESC Motor BL10A
    Batterie: ZOP Power 11.1V 1800mAh 45C Lipo Battery XT60 Plug
    Led (pour plus tard)
    J’ai aussi un module Bluetooth HC-06 Wireless Bluetooth Transceiver, car ma prise micro USB à lâché
    Radio: Turnigy 9X

    J’ai commencé depuis un petit moment le montage
    Mais je bloque sur les réglages de la carte de vol.

    Pour le moment ça ne ressemble pas a grand chose car j’ai rapidement branché les moteurs, esc et récepteur à la Naze32, pour justement m’attaquer aux réglages.

    Entre temps je connecteur micro USB de la carte à laché et je communique maintenant avec la Naze32 via Bluetooth vers Cleanflight sur mac.

    Voici comment j’ai relié mon récepteur 9X8C à ma Naze32

    Bon j’avoue que j’avais pas 50 couleurs sous la main, ca ne facilite pas la compréhension du branchement 😀

    Du coup je vous l’ai refait en schéma:

    COTE CLEANFLIGHT:

    J’ai pu tester que les moteurs étaient bien alimentés et que je pouvez les activer

    Voici quelques prints de mes réglages sur Cleanflight


    J’ai aussi vu que ma radio était bien reconnus, peut-etre pas bien réglé, mais bien reconnu.

    La ou j’ai un petit (gros) problème c’est que si je bouge les commande rien ne se passe.
    Je me suis dit qu’il devait y avoir une commande d’armement a faire…. mais rien.

    Du coup je me suis dit “Ok il y a un réglage a faire quelque part c’est obligé”, donc j’ai commencé a toucher des réglage à gauche à droite. ET LA, dans le menu MODE
    et j’ai activé le premier onglet ARM.
    Et la miracle si j’actionne les gaz (et autre) de la radio les moteurs tournes.

    Je me dis chouette j’ai trouvé le ptit truc qui me manqué. Je sauvegarde et je coupe l’alim du drone.
    Je le rallume et là plus rien !!
    Ma radio n’a à nouveau plus de contrôle. Je retourne sur cleanflight et je m’aperçois que la partie MODE ne s’est pas sauvegardé et qu’il n’y a plus de réglage.

    Et la bah… je bloque, je ne sais pas quoi faire pour sauvegarder ces paramètres.
    (et d’ailleurs je ne sais pas si ce sont les bons paramètres)

    Donc je m’en remets a vous, pour savoir si vous pouvez m’aider et si oui ou non j’arriverais a voler avec ce drone ou non 🙂

    Please help me 🙂
    Merci d’avance en tout cas

    #55878
    Cryzom
    Participant
    • Messages : 37
    • Offline

    Salut,

    je pose la question qd même: Est-ce que tu as appuyé sur le bouton « save » avant de changer de page ou de tout couper?

    Remarque: Certaines chose ne sont actives QUE quand tu branches la batterie. (ATTENTION à bien retirer tes hélices avant de bricoler ton drone)

    #55891
    Bibi
    Participant
    • Messages : 7
    • Offline

    Salut Cryzom,
    Oui oui j’ai bien fait « save » et même plusieurs fois.
    Mais à chaque fois que je coupe le drone, j’ai plus rien:(

    Est-ce que ça devrait sauvegarder ? ou y’a t’il une manip spécial a faire ?
    Est-ce que ça pourrait venir d’un problème de la Naze32 du coup ?

    et oui pas d’inquiétude pour les hélices, elle n’ont jamais était montée encore 😉

    #55894
    PapyMaurice
    Admin bbPress
    • Messages : 955
    • Offline

    Petit conseil met la zone d’armement sur la partie haute car avec cette config ta machine est censée être armée dès l’allumage ce qui est ultra dangereux.
    En plus tu n’as câblé que les 4 premières voies donc uniquement les sticks. Il faut câbler 1 ou 2 autres voies pour pouvoir utiliser les auxiliaires (interrupteurs) afin de piloter les modes de vol depuis ta radio.
    C’est peut être pour ça d’ailleurs que ta config n’a pas été sauvegardée.

    #55905
    Batbat
    Admin bbPress
    • Messages : 1850
    • Offline

    +1 avec Papy @bibi

    Il faut que tu câbles 2 autres voies minimum pour pouvoir attribuer des voies auxiliaires aux switchs.

    Fait le test et dit nous.

    Ps : big up à Bender 😉

    #55907
    Bibi
    Participant
    • Messages : 7
    • Offline

    Salut @PapyMaurice, salut @BatBat
    Merci pour vos lumières. Effectivement j’ai cablé les auxiliaires 1&2 et cette fois les configs se sauvegardent. Maintenant il me reste plus qu’a trouver la bonne config.

    Je n’ai pas eu le temps de faire plus de test. Mais c’est déjà une bonne nouvelle.
    La suite très vite 🙂

    Bender power 😉

    #55908
    Cryzom
    Participant
    • Messages : 37
    • Offline

    Content que cela fonctionne.
    Si tu veux simplifier le câblage, et éviter ce genre de déboire, si ton récepteur de commande le permet, configure le en PPM. Cela permet de passer le signal de toutes les voies sur 1 seule entrée CH1.

    Mais bon j’imagine que tu n’as pas envie d’y retoucher maintenant que cela fonctionne.

    #55934
    Bibi
    Participant
    • Messages : 7
    • Offline

    Je ne sais pas si je peux le faire avec ma radio.
    J’ai une Turnigy 9x et un récepteur 9X8C.
    Elle est d’origine. (pas de changement de firmware, ni d’antenne).

    #55937
    Batbat
    Admin bbPress
    • Messages : 1850
    • Offline

    @bibi tu n’as pas la possibilité de faire du IBUS ou du SBUS avec ça?! C’est beaucoup plus simple.

    Partage les vidéos de vol surtout ^^

    #55964
    Bibi
    Participant
    • Messages : 7
    • Offline

    @batbat Pour le moment je vais laisser comme ça. Je ne sais pas si ma Radio le fait ni si je ne suis pas assez caler pour tout comprendre, mais si ça implique d’avoir un léger gain sur la latence, je ne pense pas que mon niveau de pilotage me permette de m’en rendre compte pour le moment 🙂

    Bon sinon j’ai pu refaire des testes et ça y est je peux armer et désarmer mon drone. D’ailleurs j’ai laissé l’armement par défaut.

    Il va falloir que je me plonge maintenant sur la partie Failsafe.
    Ensuite je voudrais aussi brancher des bandeaux de LED RGB 5v à l’avant et à l’arrière. Mais j’ai un doute sur les branchements.

    Et ensuite je fais tout le montage au propre et je vous prend des photos et vidéos 😉

    #55974
    Batbat
    Admin bbPress
    • Messages : 1850
    • Offline

    @bibi sur le fond tu as raison. Penses y à l’avenir par contre, ça évite d’avoir un tas de câbles dans ton multi 😉

    En attente de tes photos et vidéos alors ^^

    #56430
    Bibi
    Participant
    • Messages : 7
    • Offline

    Ca avance!

    Soudure des moteurs
    moteur avant soudure Nighthawk 250
    moteur soudé nighthawk 250 avec tresse

    #56525
    Batbat
    Admin bbPress
    • Messages : 1850
    • Offline

    @bibi

    ESC et PCB sur le dessous du quad??!!

    Tu n’as pas peur toi!

    Pourquoi tu ne les mets pas sur les bras et ta PCB sous ta FC avec des entretoises nylon?!

    Tu verras, les pieds de ton quad vont s’envoyer en l’air rapidement, tu vas les remplacer par des patins en mousse ou ce genre de chose, et tu devras modifier l’emplacement des ESC + PCB…… J’en mets ma main à couper!!!!

    #56532
    ixil08
    Participant
    • Messages : 458
    • Offline

    @batbat, +1, mais en y regardant de plus près, je vois des entretoises sur les fixations des bras, je suppose qu’il y aura une seconde plaque carbone dessus…

    #56535
    Bibi
    Participant
    • Messages : 7
    • Offline

    Exactement @ixil08!
    Pas d’inquiétude @batbat (ne te coupe pas la main :D),
    il y a bien une autre plaque qui couvre ESC & PCB 😉

    Plaque de protection ESC & PCB Nighthawk

    #56537
    Batbat
    Admin bbPress
    • Messages : 1850
    • Offline

    @bibi @ixil08 exact! J’avais oublié cette plaque sur le NH250………

    Désolé je n’ai rien dit…..

    #56539
    McDel
    Participant
    • Messages : 269
    • Offline

    @bibi Yesss ca prend forme ^^
    Bonne fin de construction/reglages et vivement que tu postes qqs videos.

    #56540
    McDel
    Participant
    • Messages : 269
    • Offline

    @bibi Yesss ca prend forme ^^
    Bonne fin de construction/reglages et vivement que tu postes qqs videos 😛

18 sujets de 1 à 18 (sur un total de 18)
  • Vous devez être connecté pour répondre à ce sujet.